Connection Issues

Post Reply
Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Connection Issues

Post by Eru » Fri Apr 12, 2013 1:01 am

So, I think I need help.

I've set up port forwarding and my friends have pinged me and are able to get a response from my network, but are still unable to join a game I host.

I've followed the instructions in the manual, but I can't seem to get a connection on the program itself.

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Apr 12, 2013 11:43 am

Are you sure you gave your players your external IP address, and not your internal IP address? Are your friends attempting to join with unique usernames?

Do you have security software installed that might be interfering with incoming connections? What about your Windows firewall? (assuming you are on Windows)

I might be available today or tonight to help you test your setup. Let me know when would be good for you and what time zone you are in. I also need to know what program you are using (BRPG or BGE) and which version of the program.

Also, are you available for voice chat via Skype, Ventrilo, or the like?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Post by Eru » Fri Apr 12, 2013 1:11 pm

We've tried the external and internal IP address given as well as even attempting to add the port as a suffix for good measure (which does indicate failure right away)

Specifically, what is happening is that they get a window that says "establishing a connection; please wait" and it remains until it times out after I'm estimating 10 to 15 minutes. Each time we tried, we were looking up router settings and the like, so I did not necessarily time it, but it was a while.

We are running BRPG 1.7d. I am running the GM client and two of them are running the Player client (all same version and purchased recently). One of them has not tested with me and is waiting for us to confirm before purchasing.

The username rule is character names, so that should rule out any issues with non-unique usernames. I'm assuming that rule only applies to the host and the players joining the game?

I have turned off Windows Firewall and Trend Micro (my security software) with the same result. Though, even when turned on, I have both set to notify me before blocking connections and they haven't.

I'm confident that I configured the router correctly because they were not able to ping it before and are able to now.

I currently don't have a voice chat setup. That was on my to do list, but I've been limited to only doing a little at a time these days with my work schedule.

I can try to give that a shot today.

I'm on GMT-4 currently or Eastern Standard (US), state of Maryland basically. I believe that's one hour behind or earlier than you.

Because I don't have voice chat at the moment, I don't know if I could say I'm available until I do. I'll be home for the next 1.5 hour and then again very late tonight. (probably too late, like 11:30pm my time). I will have most of Saturday afternoon available however if I can't resolve anything tonight. I'll see about getting a voice chat set up.

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Apr 12, 2013 3:58 pm

Eru wrote:Specifically, what is happening is that they get a window that says "establishing a connection; please wait" and it remains until it times out after I'm estimating 10 to 15 minutes. Each time we tried, we were looking up router settings and the like, so I did not necessarily time it, but it was a while.
If it doesn't log the player into the session within 10-20 seconds, it's not going to work. No need to let it try for 10-15 minutes.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Apr 12, 2013 4:02 pm

Eru wrote:I'll be home for the next 1.5 hour and then again very late tonight. (probably too late, like 11:30pm my time).
That is 12:30 AM my time, which is actually my ideal time for testing. So let's give it a shot, even if we can only do Skype text chat. My Skype username is heruca.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Post by Eru » Sat Apr 13, 2013 12:22 am

Well...

I tried to get Skype up and running, but that doesn't seem to work for me either. I keep getting a blank UI with no options after I downloaded it. I've been troubleshooting it for 45 minutes with no resolution.

I work in technology and I can't get my personal technology to work. Epic Fail on my part!!!

Apparently, it has something to do with Internet Explorer which I had ceased using a while back. (Apparently, I shouldn't have done that.)

So... Long story short. I don't have a way to do this tonight and I still have work reports that I can't put off any longer.

Thank you for the offer, but I'm going to have to try this again another time.

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Apr 13, 2013 12:56 am

OK, no worries. Let me know when another opportune time is coming up.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Post by Eru » Sat Apr 13, 2013 1:55 am

I finally got Skype working. Wow, So I had created an account linked to Myspace a long time ago and that is why I couldn't recover my password.

Insanity!

Any way, I have a new one and its up and running.

My username is kj.eru

Are you available tomorrow afternoon or night at all?

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Apr 18, 2013 4:13 pm

Another thing occurred to me that you might want to check: Some ISPs block incoming peer-to-peer connections unless you explicitly ask them to allow this. So you might want to call your ISP's tech support line to find out if they are doing this, and/or ask them to enable it.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Cute Story

Post by Eru » Fri Apr 19, 2013 11:47 pm

So, I talked to a friendly tech support person on my ISP's website in chat. He did not know the answer to my question, so he gave me a number to the department to answer my question.

So I called and reached a nice woman at a local car dealership. I checked the number and sure enough, I was calling the right number.

Apparently, mentioning peer to peer connections on the first date in tech support chat is coming on too strong and he pulled the fake number card. Was it something I said?!?

All joking aside, I had time to explore the router settings on my own and found an additional setting preventing incoming connections. I changed it and the issue is now resolved. In fact, we were surprised with how fast the connection happened and the pre-set media assets were synced.

I knew it would be something simple I missed.

Regardless, its resolved :)

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Apr 19, 2013 11:52 pm

Glad to hear it. :)
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Apr 20, 2013 7:43 pm

By the way, what router setting was it that fixed it? In case someone else could benefit from what you discovered.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Eru
Soldier
Posts: 19
Joined: Thu Jan 31, 2013 4:32 am
Location: Baltimore, MD, United States

Post by Eru » Sat Apr 20, 2013 11:44 pm

Well... Its a bit embarrasing, but it was an adjustment to the firewall setting on my verizon router.

I know I was told to check this and I did adjust the firewall on windows and my antivirus on my computer. I had to look for advanced settings on an additional firewall on my router which solved the problem. Sorry about that.

So basically, I allowed access at the main gate to the keep and the castle gates, but forgot to tell the guards at the city gate (my network) to let them in so they could get to the castle.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests