V 1.3 - OSX 10.5.4 Connection failed when trying to host

Post Reply
hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

V 1.3 - OSX 10.5.4 Connection failed when trying to host

Post by hjmaier » Wed Aug 27, 2008 3:49 pm

Hi,

i have the problem that the error "Connection failed" apears when I try to host a game.

My settings:

Username: Hans
Port: 1626
Timeout: 5000

Oh, and I am on an Intel Mac (Macbook Pro).

I tried with an higher timeout and on other ports but with no result.

Any Idea what I can try?

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Wed Aug 27, 2008 4:23 pm

See my August 19th post on this thread. Let me know if that fixes hosting for you.
heruca wrote:I think a change I made to the BRPG INI file in v1.3 may be what's allowing wireless hosting on a Mac to work again.

If you want to try wireless hosting with older releases of BRPG, just edit the INI file in a word processor so that the SleepTime setting is 10, instead of 100. This allocates more time on OS X to network-related functions.

Save your change, then launch BRPG and try hosting.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Wed Aug 27, 2008 4:39 pm

No change.

I lookt at Battlegrounds RPG Edition.INI SleepTime is set to 10. I tried different ports.

The zip file linked in the other thread is gone.

Best regards
hj

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Wed Aug 27, 2008 4:40 pm

And I am using V1.3

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Wed Aug 27, 2008 4:46 pm

hjmaier wrote:The zip file linked in the other thread is gone.
Good thing, too. It would've reverted your BRPG installation to a pre-v1.0 version.

Only other thing I can think of to try right now is to remove the INI file from BRPG's folder, then launch BRPG and try hosting. If it doesn't help, put the INI file back in.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Wed Aug 27, 2008 4:54 pm

Hmm, no change.

Best regards
hj

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 12:27 am

There is something new to report:

When I do a portscan while I try to connect, I see port 1626 listening:

Open TCP Port: 1626 shockwave

That looks fine, or?

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Aug 28, 2008 1:20 am

That sure sounds like what you want, but it's still not making it past the Connecting screen on the host computer, right? The Chat window never opens for you after clicking the Host Game button?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 2:28 am

Yes, exactly. I do not get behind the connection screen.

I tried it with my admin account. When starting the program I get always a script error about a missing object (while displaying the splash screen). Strang thing is, that this only happens with the admin account and not with the normal account.

Best regards
Hans-Joachim

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 2:39 am

Hmm, I also checked the new firewall Apple uses. it is turned off and still the error apears.

Best regards
Hans-Joachim

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 5:45 am

Some news:

It has to do something with OSX. I jusr downloaded the Windows zip and started the program under Windoxs XP using parallels on the same MacBook Pro. Hosting works there fine.

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Aug 28, 2008 11:07 am

Are you on a wireless connection?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 11:35 am

Yes. I use A Time Capsule, connected via LAN to a DSL-Router.

Windows XP, running as a Virtual machine under Parallels uses the same connection. Strangely it works there.

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Aug 28, 2008 12:11 pm

There's a known issue that for some people (probably depending on their wireless router model) BRPG cannot host games wirelessly under Mac OS X.

Maybe something in this thread will help.

Is it very inconvenient for you to plug in an Ethernet cable for the times you need to host?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 12:23 pm

I am a lazy guy :) Don't ask me to get somewhere :P

I deactivated every network adapter (Bluetooth, FireWire, Parallels ...) and tried it.

It works now.

Thank you for your help and maybe it is a good idea to point the soloution out somehwere in the manual at a future release :)

Best regards
hj

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Aug 28, 2008 12:33 pm

Awesome! I'll run some tests on my MacBook to confirm that this is the fix.

And if so, I'll be sure to mention it in the revised User Manual.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

hjmaier
Captain
Posts: 60
Joined: Tue Aug 26, 2008 11:11 am
Location: Germany
Contact:

Post by hjmaier » Thu Aug 28, 2008 2:29 pm

An important hint: Leave Airport on ;)

Best regards
hj

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest