Hamachi issues

Post Reply
User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Hamachi issues

Post by ursus » Sat Apr 26, 2008 3:52 pm

I am able to host games, but I had trouble connecting to my friend's game this morning.

The problem with resolving this issue is that he and I live on opposite sides of the planet. He's in Japan, 13 hours ahead of me.

Any volunteers to host a game, so that I can figure out what's wrong when I try to join?

Thanks!
Last edited by ursus on Sun May 04, 2008 12:48 pm, edited 1 time in total.

User avatar
heruca
Developer
Posts: 9383
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Apr 26, 2008 4:03 pm

Sorry, bad time for me. I need to get back to work. But you should post what version you're trying to test with, so that any GM takers know which version to launch.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Sat Apr 26, 2008 4:04 pm

I'd like to test with v1.2

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Sat Apr 26, 2008 6:47 pm

If you find me on IMs I will host a game for you.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Sat Apr 26, 2008 11:21 pm

Thanks, Omnidon. I'll try looking for you during the week. Wednesday and Thursday evenings (I'm on CDT.) work best for me.

D-Miller
Sergeant
Posts: 29
Joined: Tue Mar 25, 2008 9:14 am
Location: Misawa, Japan
Contact:

Post by D-Miller » Sun Apr 27, 2008 7:42 pm

The problem connecting to your friend in Japan cound be on his/her end. I live in Japan and the IP scheme here is really odd. The IP translations can cause some major issues. I have been unable to do p2p connections directly to anyone here. I did find a solution to my problems though using Hamachi. See thread http://battlegroundsgames.com/forums/vi ... php?t=1653. (I hope this links, as I don't use boards much). Using a VPN client (which is what Hamachi is) was the only way I could get others to connect to me here.

Hope this helps a bit.
Thank you,
Dave

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Sun Apr 27, 2008 10:29 pm

D-Miller wrote:The problem connecting to your friend in Japan cound be on his/her end. I live in Japan and the IP scheme here is really odd. The IP translations can cause some major issues. I have been unable to do p2p connections directly to anyone here. I did find a solution to my problems though using Hamachi. See thread http://battlegroundsgames.com/forums/vi ... php?t=1653. (I hope this links, as I don't use boards much). Using a VPN client (which is what Hamachi is) was the only way I could get others to connect to me here.

Hope this helps a bit.
Actually, it did help, but I was still having problems. It was from your earlier post about Hamachi that we were able to do anything. My friend who lives nearby was able to connect with the friend in Osaka just fine.

Full Bleed
General
Posts: 499
Joined: Thu Oct 12, 2006 8:45 am
Contact:

Post by Full Bleed » Mon Apr 28, 2008 3:31 am

ursus wrote:Actually, it did help, but I was still having problems. It was from your earlier post about Hamachi that we were able to do anything. My friend who lives nearby was able to connect with the friend in Osaka just fine.
Do you and your local friend have different ISP's?

You might want to update your network card drivers to the latest version.

And try running some line-quality tests on your line at dslreports.com to see if you're getting some packet-loss.

Plus, Ping your friend in Osaka and post the results of that test here.

None of these suggestions are smoking guns, but they may help diagnose the problem.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Mon Apr 28, 2008 9:48 am

Thanks for your tips Full Bleed.

I checked the line quality test at dslreports.com, and that turned out fine.

I also updated the network card drivers.

I won't be able to ping my friend in Osaka right away, though. But, I'll give it a try as soon as I can.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Thu May 01, 2008 9:16 pm

I was able to connect with Omnidon hosting. No problems connecting.

But, I couldn't disconnect. Is that worth worrying about?

User avatar
heruca
Developer
Posts: 9383
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu May 01, 2008 9:24 pm

It IS rather odd not to be able to disconnect.

Were you able to receive any game data during the session, like units deployed on the map, figures moving around, chat messages, etc.?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Thu May 01, 2008 9:34 pm

We didn't do anything other than connect. I was only worried about connecting at the present. I have been able to receive data in the past prior to the connection problem.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Fri May 02, 2008 1:01 am

ursus wrote:But, I couldn't disconnect.
That's because I closed BRPG without disconnecting.

User avatar
heruca
Developer
Posts: 9383
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri May 02, 2008 1:35 am

How rude! :lol:
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Sun May 04, 2008 12:52 pm

Well now we have the connection issue narrowed down to Hamachi.

I'm able to ping my friend in Osaka if I use his external IP address, but I can't ping him through Hamachi.

I renamed the title of this thread so if anyone else has to go the Hamachi route, they can find the solution here.

I contacted tech support and will post an update here when they get back to me.

D-Miller
Sergeant
Posts: 29
Joined: Tue Mar 25, 2008 9:14 am
Location: Misawa, Japan
Contact:

Post by D-Miller » Sun May 04, 2008 8:20 pm

Hrmm, that's odd. We haven't seen any real problems with Hamachi, other than the initial connection to the Hamachi Server. The program sometimes gets stuck as a "probing" stage, but closing and re-opening it usually works.

How ours is set up is as follows:
1 - Everyone is using Hamachi
2 - GM has set the Hamachi interface as higher priority than his normal network interface
3 - GM hosts and tells everyone his Hamachi IP address (this is actually displayed by Hamachi, this makes it very easy)
4 - All players connect to the Hamachi IP address

Seems to work for us. I hope you find a solution to your issues.
Oh, one more thing that I have done. I've turned off my firewall on the Hamachi interface. As that interface is only active when I'm using it and I close the program at all other times, I'm not worried about an attack on that port. Also that port is encrypted and invite-only so even while it's active it very low risk for not having a firewall.
Thank you,
Dave

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Sun May 04, 2008 11:27 pm

D-Miller wrote:Oh, one more thing that I have done. I've turned off my firewall on the Hamachi interface. As that interface is only active when I'm using it and I close the program at all other times, I'm not worried about an attack on that port. Also that port is encrypted and invite-only so even while it's active it very low risk for not having a firewall.
Do you mean your router's firewall or does Hamachi somehow have a firewall of its own?

If my friend in Osaka has to configure his router, that's a big problem because his Japanese isn't good enough to figure out his ISP's proprietary hardware.

D-Miller
Sergeant
Posts: 29
Joined: Tue Mar 25, 2008 9:14 am
Location: Misawa, Japan
Contact:

Post by D-Miller » Mon May 05, 2008 7:19 am

I use the Windows XP firewall running on my workstation. I have disabled it for that one adapter. That option is available from the advanced settings of the Windows Firewall.

If Hamachi is connecting then your router is probably set up okay. Although on the Hamachi website they do recommend forwarding a couple of ports on your router. I don't remember which ones off the top of my head, but it is listed in their help on the Hamachi site.
Thank you,
Dave

User avatar
ursus
General
Posts: 222
Joined: Sun Nov 25, 2007 2:28 am
Location: Chicago, Illinois, USA
Contact:

Post by ursus » Tue May 06, 2008 12:49 pm

D-Miller wrote:I use the Windows XP firewall running on my workstation. I have disabled it for that one adapter. That option is available from the advanced settings of the Windows Firewall.
Finally had a chance to test Hamachi again with my friend. I had him turn off the Windows XP firewall on his computer, and I could ping him with ease.

-D-Miller, could you post a few more details on the firewall settings you use?

D-Miller
Sergeant
Posts: 29
Joined: Tue Mar 25, 2008 9:14 am
Location: Misawa, Japan
Contact:

Post by D-Miller » Tue May 06, 2008 5:18 pm

Here's how to disable the firewall on the Hamachi interface:
Go to the control panel. (I use the classic view)
Select "Windows Firewall".
In the "Advanced" tab, un-check "Hamachi" and press "OK"

Now the Hamachi interface is no longer firewalled. Windows will give you a pop-up every time you log in due to the one interface not having a firewall, you can simply ignore the pop-up.

I also set up port triggering on the following two ports on my router: 12975 and 32976 for both UDP and TCP.

Again it's pretty safe to turn off the firewall for the Hamachi interface as long as you are only runign Hamachi while you are using BRPG due to the way Hamachi works.
Thank you,
Dave

User avatar
heruca
Developer
Posts: 9383
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue May 06, 2008 5:28 pm

Thanks for providing assistance with this, D-Miller. I'm lost when it comes to Hamachi.

+1 Karma
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

D-Miller
Sergeant
Posts: 29
Joined: Tue Mar 25, 2008 9:14 am
Location: Misawa, Japan
Contact:

Post by D-Miller » Thu May 08, 2008 7:46 pm

Yay! That gives me just enough to Initiate... Grade 1 here I come. =)
Thank you,
Dave

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest