Page 1 of 1

BGE 1.6 Beta Question

Posted: Sat Jan 10, 2015 11:12 am
by rab46
I tried to convert one of my existing game conversions from BGE 1.5 to BGE 1.6 beta and have a question. After completing the conversion, all existing or newly created components act like they are unmoveable, regardless of their unmoveable setting. Everything I try to drag instantly jumps back to its' initial position regardless of whether I have "unmoveable" selected in the sub-menu or not. Wondering if it's something I did (or didn't do :D) or if this is a real issue.

Re: BGE 1.6 Beta Question

Posted: Sat Jan 10, 2015 4:41 pm
by heruca
Uh oh.

This is in solo mode, or in a networked game?

Unmovable units shouldn't allow dragging them in the first place. The snap-back behavior you described might be something else. Will investigate and get back to you.

Have you already tried relaunching BRPG to see if this misbehavior goes away?

Have you got a backup copy of your un-updated game file stored in a safe place? If not, look for something useable in the Autosaves directory before it gets overwritten by newer autosaves.

Re: BGE 1.6 Beta Question

Posted: Sat Jan 10, 2015 5:05 pm
by heruca
Unable to duplicate what happened to you. I suppose that's a good thing, in the grand scheme of things. :)

Could you email me the affected game file for analysis?

Re: BGE 1.6 Beta Question

Posted: Sat Jan 10, 2015 5:39 pm
by rab46
It was playing solo. I did shut down BGE and restart it, didn't make any difference. Looks like I can move card stacks around with the mouse but not individual cards or components. One other observation; I can move components with keys (1-9), but not by dragging with the mouse. I copied everything over to a new directory prior to messing with BGE 1.6 so I have the uncoverted game file. I'll send you both the original and the converted game files via email. Let me know what you find. Thanks.

Re: BGE 1.6 Beta Question

Posted: Sat Jan 10, 2015 7:38 pm
by heruca
Try out the fixed file that I emailed you and let me know if the snap-back behavior is fixed.

Re: BGE 1.6 Beta Question

Posted: Sun Jan 11, 2015 1:47 am
by heruca
I was able to partially duplicate the problem. It seems the snap-back behavior engages for units set to Unmovable when you drag them while snap-to-grid is disabled.

The error does not occur in BRPG v1.8c, so I must've missed some snippet of code when I ported the feature over from the other app.

Re: BGE 1.6 Beta Question

Posted: Sun Jan 11, 2015 2:34 am
by heruca
Try setting the grid type to hex, even if you are hiding the grid, and see if that avoids the behavior. Also try enabling or disabling snap-to-grid.

I have found a bug in the code that handles unmovable units, and am preparing a quick patch.

What I still don't get is why your units are all acting like unmovable units, when that does not happen for me at all. Might be a Windows-specific bug.

Re: BGE 1.6 Beta Question

Posted: Mon Jan 12, 2015 9:12 am
by heruca
A fix for this bug is now available here.