BUG: Corrupt Load (RC1) [FIXED]

An archive for tracking bugs that have already been fixed
Locked
User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

BUG: Corrupt Load (RC1) [FIXED]

Post by Omnidon » Tue Jun 06, 2006 8:04 pm

I have no idea what caused it but when I was testing health halos, I had to start over because after loading my save file I got this:

http://allinyourmind.net/images/BRPG/testinghealth.bge

(I thought at first it was the Unique Name Crash, but I wasn't able to duplicate it)

That encounter always loads like this:

[Screenshot Removed by Omni]
Last edited by Omnidon on Mon Dec 18, 2006 2:31 am, edited 6 times in total.

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue Jun 06, 2006 10:05 pm

Gorgeous table, though. :lol:

There's clearly some encounter corruption going on in the latest version or two. Once I fix it, a lot of the bugs reported in the last few days should be squashed.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue Jun 06, 2006 10:22 pm

I replaced the VOID values with appropriate data. Try to copy this into your Encounter, save it, then load it in BRPG to see if it works.

[[6, 0, "Grass", "Square", 1, "A", 0, 0, 75, 0, 0], [51, "Construct", 398.5000, 223.9600, 0, "Figure", 1, 0, 0, 0, 0, 0, "A", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "None", 16, 81, 101, 102, "GM", "", "Clear", 15, 1, "S1", [], 0, "None", "Above"], [52, "Construct", 581.5000, 223.9600, 0, "Figure", 1, 0, 0, 0, 0, 0, "B", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "Green", 18, 82, 103, 104, "GM", "", "Clear", 17, 1, "S1", [], 0, "None", "Above"], [53, "Construct", 764.5000, 223.9600, 0, "Figure", 1, 0, 0, 0, 0, 0, "C", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "Yellow", 20, 83, 105, 106, "GM", "", "Clear", 19, 1, "S1", [], 0, "None", "Above"], [54, "Construct", 947.5000, 223.9600, 0, "Figure", 1, 0, 0, 0, 0, 0, "D", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "Red", 22, 84, 107, 108, "GM", "", "Clear", 21, 1, "S1", [], 0, "None", "Above"], [55, "squidy", 398.5000, 40.9900, 0, "Figure", 1, 0, 0, 0, 0, 0, "1", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "None", 24, 85, 109, 110, "GM", "", "Clear", 23, 1, "S1", [], 0, "None", "Above"], [56, "squidy", 581.5000, 40.9900, 1, "Figure", 1, 0, 1, 0, 0, 0, "2", 100, 0, 1, 0, "GM", "", 0, [], [], [], [], 0, 2, [], "None", 26, 86, 111, 112, "GM", "", "Clear", 25, 1, "S1", [], 0, "None", "Above"]]
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Wed Jun 07, 2006 1:07 am

I just wanted the forum to show the changes I made in color. It worked, as far as I can tell.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Wed Jun 07, 2006 1:11 am

Ah ok that's what confused me.

With those changes, it works now ;-)

Did you fix what caused the problem in the first place?

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Wed Jun 07, 2006 1:14 am

Not yet. Will do it tomorrow. Need sleep.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Wed Jun 07, 2006 1:16 am

No sleep for you! :twisted:
Heh we already had *that* conversation though :roll:

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Tue Jul 18, 2006 12:22 pm

bump.
Did you ever fix this?

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue Jul 18, 2006 1:58 pm

Sort of. See the green highlights in the post above? I've added code to fill in default values should a VOID value be present. This should prevent Encounters from becoming corrupted when saved. It's already saved me once. But it's more of a band-aid fix. I suspect that the real culprit is that those values are void in the first place, and I think that's what's causing the "unique name bug" crashes, too.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Mon Dec 18, 2006 2:34 am

-- Marked Fixed --

Replacement of the broken flash component mentioned elsewhere likely snuffed out any lingering life that this bug had ;-)

Locked

Who is online

Users browsing this forum: No registered users and 3 guests