Page 1 of 2

End turn button oddly placed

Posted: Sun Mar 15, 2009 6:42 am
by Nom
End turn button is drawn half-on, half-off the bottom edge of the map window.

Posted: Sun Mar 15, 2009 8:43 am
by heruca
Unable to duplicate. Did you use the maximize button on the map window? If so, does resizing the map window manually fix the problem? Are you running in fullscreen mode?

Posted: Sun Mar 15, 2009 11:41 pm
by Nom
I'll try to get a screenshot when we next run. I'm running a client with dual monitors (map on secondary monitor), in windowed mode.

Resizing, zooming or scrolling the map window redraws the button half-on, half-off the bottom of the window each time.

Posted: Mon Mar 16, 2009 1:42 am
by heruca
Check your Battlegrounds INI file and let me know if the Fullscreen setting is set to 1 (TRUE).

Posted: Tue Mar 17, 2009 12:45 am
by Nom

Code: Select all

[Settings]
SleepTime=10
BackgroundSleepTime=1000
BackgroundAnimation=1
UseTitleBar=0
;FullScreen=0
ResizeStage=0
SingleInstance=1
[Lingo]
DisplayFullLingoErrorText=1
[Memory]
ExtraMemory=10240
Is that semi-colon supposed to be there?

Posted: Tue Mar 17, 2009 9:14 am
by heruca
The semicolon means the line has been commented out (i.e., disabled). Looks fine. Something else must be causing the issue.

Is anyone else experiencing this, on any OS?

Posted: Tue Mar 17, 2009 10:17 am
by Omnidon
Shows up fine for me, using windowed mode & multiple monitors on WinXP.

Posted: Tue Mar 17, 2009 10:26 am
by heruca
Nom, is there now a folder in your "Support Files" folder called "Place Contents in Support Files folder"? If so, the patch was not installed correctly.

Posted: Wed Mar 18, 2009 8:15 pm
by Nom
Nothing untoward in there.

Here's a listing:

Code: Select all

-rw-r--r--@  1 {user} {group}     24580 27 Feb 06:11 .DS_Store
-rw-r--r--@  1 {user} {group}  35545306 27 Feb 00:27 AoE Overlays.cxt
-rw-r--r--@  1 {user} {group}      2552 15 Mar 22:22 Blank Cast.cxt
-rw-r--r--@  1 {user} {group}   3934958 15 Mar 22:22 Browser.dxr
-rw-r--r--@  1 {user} {group}   2110749  3 Feb 07:14 Card Table.dxr
-rw-r--r--@  1 {user} {group}     19272 16 Jan 23:44 Charts.dxr
-rw-r--r--@  1 {user} {group}     70880 16 Jan 23:44 ChatMIAW.dxr
-rw-r--r--@  1 {user} {group}    232112 16 Jan 23:44 Color Picker.dxr
-rw-r--r--@  1 {user} {group}   4089320 27 Feb 06:06 Dice Roller.dxr
-rw-r--r--@  1 {user} {group}    131566 16 Jan 23:45 DrawMIAW.dxr
-rw-r--r--@  1 {user} {group}  46627427 27 Feb 00:27 Figure Bases.cxt
-rw-r--r--@  1 {user} {group}       993 17 Mar  2006 GMNotepad.rtf
-rwx------   1 {user} {group}       162 28 Apr  2007 GMNotepad.txt
-rw-r--r--@  1 {user} {group}   6842045 27 Feb 00:27 Halos.cxt
-rw-r--r--@  1 {user} {group}   3305216 11 Mar 06:36 Map.dxr
-rw-r--r--@  1 {user} {group}    883428 27 Feb 00:27 Movement Guides.cxt
-rw-r--r--@  1 {user} {group}       552 17 May  2007 Notepad.rtf
-rwxr--r--   1 {user} {group}       205 10 Feb  2006 Notepad.txt
-rw-r--r--@  1 {user} {group}    175327 27 Feb 00:27 TS Setup Wizard.dxr
-rw-r--r--@  1 {user} {group}     68231 27 Feb 00:27 Table Support.cxt
-rw-r--r--@  1 {user} {group}     18478 16 Jan 23:45 Text Macros.dxr
-rw-r--r--@  1 {user} {group}    418221 27 Feb 00:27 Turn Sequencer.dxr
-rw-r--r--@  1 {user} {group}     43190 10 Mar 03:27 UIMIAW.dxr
-rw-r--r--@  1 {user} {group}  76422762 15 Mar 22:22 User Cast.cxt
-rw-r--r--   1 {user} {group}    220421 28 Jun  2007 aleXtra_ILtable.dcr
-rw-r--r--   1 {user} {group}     43808 29 Jul  2006 goMU.dcr
-rw-r--r--   1 {user} {group}     54456  1 Oct  2004 tableScripts.dcr
If there's nothing obvious, I'll just wait for 1.4f. I generally do a fresh install and then copy macros, labels, and media asset bundles over, so if there are config oddities that will get everything back in sync.

Posted: Wed Mar 18, 2009 8:16 pm
by Nom
PS: I just noticed that this whole thing was in someone else's thread, not a new one. Sorry about that. Is it possible for a mod to splice it out?

Posted: Wed Mar 18, 2009 9:08 pm
by heruca
Nom wrote:I'll try to get a screenshot when we next run. I'm running a client with dual monitors (map on secondary monitor), in windowed mode.

Resizing, zooming or scrolling the map window redraws the button half-on, half-off the bottom of the window each time.
That might be a clue. Does the button get drawn in proper position when the map window is on the primary monitor?

What resolutions are your two displays running at?

Posted: Thu Mar 19, 2009 1:02 am
by Nom
Haven't tried with map in main window. Next session is in a week, so I'll do it then (I only have client).

Main display (which has everything except the map) is 1440x900 (PowerBook G4 17").

Secondary display is DVI 1280x1024 external monitor (non-Apple).

Posted: Fri Mar 20, 2009 3:39 pm
by heruca
This may be fixed for v1.4f. I can't be sure, since I was never able to replicate the bug on my system, but please let me know one way or the other once v1.4f is released.

Posted: Sat Mar 21, 2009 12:15 pm
by Kazander
If it matters at all at this point, I have the same problem. 1.4e, WinVista, problem occurs with single monitor (1920x1200) or dual monitor (1920x1200 + 1024x768).

When you toggle fullscreen mode, the task bar at the bottom of the page does not disappear, like it usually does with full screen applications (I haven't used fullscreen mode before so I don't know if this is intentional or not). But the Stepping button does appear properly just above the task bar. In (BRPG maximized) windowed mode, it looks like the button is coming up behind the task bar (or possibly the bottom edge aligns with the bottom edge of the desktop, underneath the task bar), so it is approximately centered on the top edge of the task bar, half visible and half not. In (BRPG not maximized) windowed mode, it's worse. Probably 3/4 of the button drops beneath the lower edge of the BRPG window.

Furthermore, fullscreen mode toggling does not work properly when the BRPG window is 'maximized' prior to toggling. The only visible effect is the Stepping button disappears completely. When going fullscreen from a non-maximized window, it mostly works except for leaving the taskbar at the bottom of the screen.

I've attached screenshots of the stepping button in various modes so you can see.

Posted: Sat Mar 21, 2009 12:20 pm
by heruca
To truly run in Fullscreen mode, you need to edit BRPG's INI file (while BRPG is not running) so that FullScreen=1 and there should not be a semi-colon at the beginning of the line.

After doing that, do you still get the same behavior, or is the Step button properly aligned? It should at least hide the Task Bar.

Posted: Sat Mar 21, 2009 1:02 pm
by Kazander
With the INI filed edited so that FullScreen=1, with no semicolon, the behaviour of the button is the same.

It should be noted though that FullScreen mode does not appear to work as intended though. Even though my Task Bar at the bottom of the screen and my custom toolbar at the top disappear, the space they normally take up is still not taken up by BRPG instead. So there is a blank space not unlike letterboxed mode for widescreen DVDs at the top and bottom of the screen.

Posted: Sat Mar 21, 2009 1:16 pm
by heruca
On my XP system, if I do the above, launch BRPG, then select the Fullscreen Mode command, I'm able to get BRPG to fill the screen. At least I can drag the bottom edge of the map window to a couple of pixels shy of the bottom. And the Step button is correctly positioned.

Perhaps it's different on Vista?

Posted: Sat Mar 21, 2009 1:50 pm
by Kazander
Quite possibly.

It's not an Aero interface thing though, because it's happens with Windows Vista Basic and Windows Classic modes too though.

Given that Windows 7 is nearly functionally identical to Vista, it's likely to be something that doesn't go away either.

Posted: Mon Mar 23, 2009 12:12 am
by nightwalker450
Maybe related, maybe not..

Had an interesting thing happen today where everyone's end turn button disappeared. Just the text showed on the bottom of the screen, but there was no button.

EDIT: Actually all the buttons had vanished, check boxes, buttons etc in figure editing and on the turn sequencer. Just the text was showing for them none of the actual controls. Its happened before, but this time really stood out because the players had a button they were used to seeing as well.

Posted: Tue Mar 31, 2009 6:31 pm
by Nom
By the way, the exact same distro (I just copied the folder over) on Intel with 10.5.6 had the button placed correctly. I didn't check again on the previous machine, because I forgot that I'd upgraded my computer in the intervening fortnight!

Posted: Tue Mar 31, 2009 7:16 pm
by heruca
If it happens again, try pressing the [|] hotkey (Shift key required). That will resize your map window to fit your display's resolution exactly, which in turn should cause the "End My Turn" button to be properly positioned.

Posted: Thu Jun 18, 2009 11:59 pm
by Kazander
FYI....this is happening again in 1.4g (win).

I know you really didn't want to hear that, but....I cannot help it.

The [|] hotkey doesn't help, either.

Posted: Fri Jun 19, 2009 12:10 am
by nightwalker450
With WinXP [|] seems to ignore the space necessary for the Taskbar. Which puts the End My Turn Button just below.

Though the general problem seems to be with something in Vista, perhaps this tidbit might be a clue to the problem?

Posted: Fri Jun 19, 2009 12:15 pm
by heruca
Very odd, since I use Windows XP for my testing, and the button is properly positioned, even if I set the Task Bar to autohide.

Fortunately, since there's now a hotkey (Shift-RETURN) to step the sequence, this bug isn't quite so critical.

Posted: Sat Jun 20, 2009 1:03 am
by Omnidon
That's never happened for me in WinXP, though I use the Classic theme.